Bug 691820 - Regression: lx5000 device locks up
Summary: Regression: lx5000 device locks up
Status: RESOLVED FIXED
Alias: None
Product: Ghostscript
Classification: Unclassified
Component: Regression (show other bugs)
Version: master
Hardware: PC Linux
: P1 normal
Assignee: Henry Stiles
QA Contact: Bug traffic
URL:
Keywords:
: 692399 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-12-07 04:44 UTC by Marcos H. Woehrmann
Modified: 2011-08-18 15:30 UTC (History)
3 users (show)

See Also:
Customer:
Word Size: ---


Attachments
launch_leaflet.ps (3.25 MB, application/postscript)
2011-08-04 23:00 UTC, Till Kamppeter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcos H. Woehrmann 2010-12-07 04:44:39 UTC
Starting with r11902 the following command locks up:

  ./bin/gs -sDEVICE=lx5000 -o test.tmp ./tiger.eps

With r11901 and earlier versions the command finishes in about 2 seconds.
Comment 1 Michael Vrhel 2010-12-07 06:11:01 UTC
OK.  I will find out what is going on with tiger.eps .  Very strange.
Comment 2 Michael Vrhel 2010-12-07 06:22:15 UTC
This thing works fine for me in release and debug mode.  I am wondering if there is a 64bit issue going on.
Comment 3 Alex Cherepanov 2010-12-07 15:15:08 UTC
I can reproduce this in HEAD on AMD64, i686, ppc32 boxes under several recent
Linux distributions.
Comment 4 Michael Vrhel 2011-06-11 17:01:38 UTC
Assigning to Henry to have a look.
Comment 5 Henry Stiles 2011-07-20 15:40:34 UTC
This has mysteriously "gone away" for Chris and I.  Assign back if you can reproduce it.
Comment 6 Marcos H. Woehrmann 2011-08-02 16:52:55 UTC
Gone away for me too.  Will reopen if I can figure out how to make it come back.
Comment 7 Till Kamppeter 2011-08-04 23:00:28 UTC
Created attachment 7758 [details]
launch_leaflet.ps

The attached file hangs on the third page with this command line:

gs -sDEVICE=lx5000 -sOutputFile=/dev/null ~/ghostscript/testfiles/launch_leaflet.ps

Using current snapshot of the Ghostscript 9.04 branch (probably identical with the release) on Ubuntu Oneiric 64-bit.
Comment 8 Till Kamppeter 2011-08-04 23:01:07 UTC
Bug reproduced, reopening ...
Comment 9 Henry Stiles 2011-08-16 23:04:44 UTC
Fixed in http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=9c074dc

Device removed.
Comment 10 Marcos H. Woehrmann 2011-08-17 04:33:26 UTC
*** Bug 692399 has been marked as a duplicate of this bug. ***
Comment 11 Till Kamppeter 2011-08-18 15:30:18 UTC
Updated the OpenPrinting web site (drivers "lx5000" and "pbm2l7k" appropriately, recommending to use the "pbm2l7k" driver.