Bug 689150 - /rangecheck in run with x11alpha
Summary: /rangecheck in run with x11alpha
Status: RESOLVED FIXED
Alias: None
Product: Ghostscript
Classification: Unclassified
Component: PDF Interpreter (show other bugs)
Version: master
Hardware: PC Linux
: P4 normal
Assignee: Michael Vrhel
QA Contact: Bug traffic
URL:
Keywords: bountiable
: 690813 690823 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-03-24 16:04 UTC by Ralph Giles
Modified: 2011-04-09 04:54 UTC (History)
6 users (show)

See Also:
Customer:
Word Size: ---


Attachments
LGMv7a_low.pdf (1.40 MB, application/pdf)
2007-03-24 16:06 UTC, Ralph Giles
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ralph Giles 2007-03-24 16:04:28 UTC
The file fails with head (at least r7797) when using the x11alpha device at
resolutions below 300dpi. It does not seem to occur with the x11 device, with or
without -dTextAlphaBits=4 or -dGraphicsAlphaBits=4.

$ debugobj/gs -r72 -sDEVICE=x11alpha -I../fonts LGMv7a_low.pdf
GPL Ghostscript SVN PRE-RELEASE 8.57 (2007-03-15)
Copyright (C) 2007 artofcode LLC, Benicia, CA.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Processing pages 1 through 16.
Page 1
Error: /rangecheck in --run--
Operand stack:
   --dict:7/7(L)--   24.0   0.0
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--  
--nostringval--   false   1   %stopped_push   1797   1   3   %oparray_pop   1796
  1   3   %oparray_pop   1792   1   3   %oparray_pop   --nostringval--  
--nostringval--   2   1 16   --nostringval--   %for_pos_int_continue  
--nostringval--   --nostringval--   false   1   %stopped_push   --nostringval--
  --nostringval--
Dictionary stack:
   --dict:1084/1123(ro)(G)--   --dict:2/20(G)--   --dict:74/200(L)--  
--dict:74/200(L)--   --dict:105/127(ro)(G)--   --dict:266/300(ro)(G)--  
--dict:21/25(L)--   --dict:4/6(L)--   --dict:20/20(L)--   --dict:3/5(L)--
Current allocation mode is local
GPL Ghostscript SVN PRE-RELEASE 8.57: Unrecoverable error, exit code 1
Comment 1 Ralph Giles 2007-03-24 16:06:14 UTC
Created attachment 2856 [details]
LGMv7a_low.pdf

attaching problem file
Comment 2 Ralph Giles 2009-07-30 10:32:54 UTC
Still an issue with 8.70rc1. Passing to Michael along with the rest of the
x11alpha transparency/alpha bugs.
Comment 3 Alex Cherepanov 2009-10-11 12:37:31 UTC
*** Bug 690813 has been marked as a duplicate of this bug. ***
Comment 4 Ken Sharp 2009-10-16 04:40:39 UTC
*** Bug 690823 has been marked as a duplicate of this bug. ***
Comment 5 Till Kamppeter 2010-06-23 10:49:21 UTC
Problem still present in 8.71 and also in SVN rev 11415.
Comment 6 Paul Schreiber 2010-08-28 21:05:04 UTC
I see the error with 7.07 and 8.64. However, version 8.71 is working fine on my file.
Comment 7 Hin-Tak Leung 2010-08-30 17:09:30 UTC
(In reply to comment #6)
> I see the error with 7.07 and 8.64. However, version 8.71 is working fine on my
> file.

Transparency/alpha type of bugs are usually sensitive to resources - just to be sure, are you testing on the same box?
Comment 8 Paul Schreiber 2010-08-30 17:42:27 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > I see the error with 7.07 and 8.64. However, version 8.71 is working fine on my
> > file.
> 
> Transparency/alpha type of bugs are usually sensitive to resources - just to be
> sure, are you testing on the same box?

 I ran in to this using MediaWiki and made detailed notes on their support page:
http://www.mediawiki.org/wiki/Manual_talk:Image_Administration#Error_creating_thumbnail_convert:_missing_an_image_filename

Yes, same box, with successive command-line calls. Could be I have an edge case that *was* fixed. Just adding another data point.
Comment 9 Michael Vrhel 2011-04-09 04:54:48 UTC
Fixed with rev 12380