Bug 690823 - Error: /rangecheck in --run-- on some PDF files
Summary: Error: /rangecheck in --run-- on some PDF files
Status: RESOLVED DUPLICATE of bug 689150
Alias: None
Product: Ghostscript
Classification: Unclassified
Component: PDF Interpreter (show other bugs)
Version: 8.70
Hardware: PC Linux
: P4 normal
Assignee: Alex Cherepanov
QA Contact: Bug traffic
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-16 04:13 UTC by Adrian Johnson
Modified: 2009-10-16 04:40 UTC (History)
0 users

See Also:
Customer:
Word Size: ---


Attachments
inkscape.pdf (4.32 KB, application/download)
2009-10-16 04:15 UTC, Adrian Johnson
Details
gnome-report-2009-Q2.pdf (166.95 KB, application/download)
2009-10-16 04:16 UTC, Adrian Johnson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adrian Johnson 2009-10-16 04:13:40 UTC
I have been getting reports of Ghostcript crashing on some cairo generated PDF
files. Adobe Reader and Poppler display the same files correctly with out
errors. I can not see anything obviously wrong with the PDF files so it appears
it may be a Ghostscript bug.
Comment 1 Adrian Johnson 2009-10-16 04:15:31 UTC
Created attachment 5495 [details]
inkscape.pdf

PDF file that crashes ghostscript.
Comment 2 Adrian Johnson 2009-10-16 04:16:02 UTC
Created attachment 5496 [details]
gnome-report-2009-Q2.pdf

Another PDF file that crashes ghostscript.
Comment 3 Ken Sharp 2009-10-16 04:40:38 UTC
Looks like yet another manifestation of the x11alpha driver failing with
transparent PDF files. The PDF works fine on GS under Windows, and using the X11
device, fails as described with the x11alpha device.

See #689150, #689734, #690813


*** This bug has been marked as a duplicate of 689150 ***