Bug 700524 - cups-pdf prints blank pages from some applications
Summary: cups-pdf prints blank pages from some applications
Status: RESOLVED INVALID
Alias: None
Product: Ghostscript
Classification: Unclassified
Component: PDF Interpreter (show other bugs)
Version: 9.26
Hardware: PC Linux
: P4 normal
Assignee: Ken Sharp
QA Contact: Bug traffic
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-26 00:41 UTC by Juraj
Modified: 2019-02-10 12:03 UTC (History)
1 user (show)

See Also:
Customer:
Word Size: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juraj 2019-01-26 00:41:08 UTC
Hello,
I will state this right at the beginning: I do not know where the source of this problem is, if you know please redirect me there.

My problem is that cups-pdf prints blank pages when it is called from qt5 applications like Kate, Kmail or Falkon.
And it surprisingly works in GTK ones like Geany or Palemoon.

I know that the Print dialog itself contains feature called "Print to file" which can be used as workaround, but it is more work than just clicking print and letting cups do all the work.

To fix this bug I tried many things, I resetted all option in conf files, installed newest updates, searched wiki / internet, cursed devs and so on.... but nothing changed the result.

The created pdf file is around 2.3Kib big with set title, creator, time etc. but is completly blank.

So my guess is that there is some kind of an error when processing tasks from these programs (see cups-pdf.log)

So my guess is that there is some kind of an error when processing tasks from Kate (see cups-pdf-printer.log)
> Wed Jan 23 18:52:12 2019 [DEBUG] ghostscript has finished: 256

Cups-pdf-printer.log: https://paste.artixlinux.org/view/ba6519e2
Cupsd-error.log: https://paste.artixlinux.org/view/438eb813

SOFTWARE INFORMATION
Operating System: Artix (Arch Linux) with latest updates until now
cups: version: cups 2.2.10
cups-filters version: 1.22.0
cups-pdf: cups-pdf 3.0.1
GhostScript: 9.26

This post is ~copy of forum article where I asked for help with no result.
https://forum.artixlinux.org/index.php/topic,836.msg6444/topicseen.html

Thank you for the help.
Comment 1 Chris Liddell (chrisl) 2019-01-26 08:22:29 UTC
In both your logs, the only Ghostscript command lines I can see are referencing the ps2write device, which outputs Level 2 Postscript - which seems a strange thing to do when the required output is PDF.

I'm sorry, but none of us really know much about CUPS, so I'd suggest contacting the CUPS maintainers and seeing if they will help narrow down the problem. If it turns out to be Ghostscript (and I'm in no way denying that it might be!), then we'll need a Ghostscript command line and the Ghostscript input file to reproduce and debug the problem.

Feel free to reopen this bug, and attach the input file here, when you've got that  information available.
Comment 2 Ken Sharp 2019-02-10 12:03:13 UTC
Lacking any further information to go on I can't see that this is a Ghostscript problem, and I'm closing it.