Bug 695750 - Increasing memory usage with Windows display device since 4e44c995
Summary: Increasing memory usage with Windows display device since 4e44c995
Status: RESOLVED FIXED
Alias: None
Product: Ghostscript
Classification: Unclassified
Component: Graphics Library (show other bugs)
Version: master
Hardware: PC Windows 7
: P2 normal
Assignee: Ray Johnston
QA Contact: Bug traffic
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-18 07:33 UTC by Ken Sharp
Modified: 2016-07-22 13:14 UTC (History)
2 users (show)

See Also:
Customer:
Word Size: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Sharp 2014-12-18 07:33:59 UTC
Created attachment 11391 [details]
customer sample file

The attached customer file, when run with "gswin32c 004580_ImputMix_Test_FPR.pdf" uses increasing amounts of memory as the job progresses, and also seems (subjectively) to be slower than the 9.10 release.

Chris has bisected this to commit:

4e44c995bcc7a2aa6c32e23cb73fd532a93f5b1c

"Fix bug 689805: Use a clist for pages with transparency that need lots of RAM"
Comment 1 Ken Sharp 2014-12-18 07:35:11 UTC
Assigning to Ray since it seems to be clist related, and related to one of his commits.
Comment 2 Chris Liddell (chrisl) 2014-12-19 01:59:38 UTC
Fixed in:
http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=09def28a

Note that the performance drop between 9.10 and 9.15 is mostly due to now using clists for the transparency groups - setting something like -dMaxBitmap=64m on the command line will keep performance sprightly, but prevent memory use explosions with transparency groups covering large areas.
Comment 3 Ray Johnston 2014-12-19 17:51:28 UTC
Just pointing out that setting -dMaxBitmap=1g or larger will not always use
1 Gb of RAM, but will only use the same amount as the display device did with
the code prior to the implementation of the automatic 'clist' mode for this
type of device.
Comment 4 Ken Sharp 2016-07-22 13:14:05 UTC
*** Bug 696943 has been marked as a duplicate of this bug. ***