Bug 693940 - gs/ijs/configure.ac calls deprecated AM_PROG_CC_STDC
Summary: gs/ijs/configure.ac calls deprecated AM_PROG_CC_STDC
Status: RESOLVED FIXED
Alias: None
Product: Ghostscript
Classification: Unclassified
Component: Build Process (show other bugs)
Version: master
Hardware: PC Linux
: P4 normal
Assignee: Chris Liddell (chrisl)
QA Contact: Bug traffic
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-27 20:40 UTC by James Cloos
Modified: 2013-05-03 09:24 UTC (History)
0 users

See Also:
Customer:
Word Size: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James Cloos 2013-04-27 20:40:39 UTC
The error message says to call AC_PROG_CC, which that file already does, so the AM_PROG_CC_STDC line should be deleted from gs/ijs/configure.ac.

I read a commit message stating that you do now want to use automake, but ijs, jbig2dec, jpeg, lcms, lcms2, libpng, openjpeg and tiff, as found in ghostpdl master, do use it and AM_PROG_CC_STDC causes the build to fail with automake-1.13.
Comment 1 Chris Liddell (chrisl) 2013-05-03 09:24:15 UTC
Fixed in:
http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=e7de6bf7

Thanks for pointing it out.