Bug 692069 - barcode not displaying
Summary: barcode not displaying
Status: RESOLVED DUPLICATE of bug 688647
Alias: None
Product: Ghostscript
Classification: Unclassified
Component: PDF Interpreter (show other bugs)
Version: 0.00
Hardware: PC Linux
: P4 normal
Assignee: Alex Cherepanov
QA Contact: Bug traffic
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-14 21:55 UTC by Lee Howard
Modified: 2011-04-16 17:52 UTC (History)
0 users

See Also:
Customer:
Word Size: ---


Attachments
sample PDF with barcode missing when interpreted with gs (118.87 KB, application/pdf)
2011-03-14 21:55 UTC, Lee Howard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lee Howard 2011-03-14 21:55:21 UTC
Created attachment 7368 [details]
sample PDF with barcode missing when interpreted with gs

I'm attaching a PDF which does not display the barcodes when interpreted with gs.  The barcodes do display on the same system with Adobe Reader.  What's going on here?
Comment 1 Ken Sharp 2011-03-15 08:28:29 UTC
The barcodes are Widget Annotations in an Acrobat interactive form. Ghostscript doesn't support interactive features of Acrobat forms so we don't attempt to do anything with widget annotations which can include features like buttons.

Acrobat reader is of course an interactive application and so does support interactive features.

In this particular case the Widget annotation is read-only and more importantly is also a text type (it uses a custom TrueType font to generate the barcode from the text).

Alex may decide this is possible to support, so I'll leave it up to him.
Comment 2 Alex Cherepanov 2011-03-15 13:28:34 UTC
I'd say that GS doesn't _fully_ support annotations without appearance
streams.

In particular, the file has /NeedAppearances flag off. So GS doesn't even
try to generate appearance streams.

Next, there are bugs in handling /DV and /DR attributes.
Comment 3 Alex Cherepanov 2011-04-16 17:52:38 UTC
This is yet another file with XML forms produced by Adobe LiveCycle .
Ghostscript still doesn't support XML forms.
Disabling /XFA attribute makes the bar code disappear on Acrobat Reader.

*** This bug has been marked as a duplicate of bug 688647 ***