Bug 691981 - printing a certain file fails
printing a certain file fails
Status: RESOLVED FIXED
Product: Ghostscript
Classification: Unclassified
Component: CUPS driver
8.71
PC Linux
: P4 normal
Assigned To: Till Kamppeter
Bug traffic
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-18 13:43 UTC by Fanen
Modified: 2011-07-14 13:56 UTC (History)
4 users (show)

See Also:
Customer:
Word Size: ---


Attachments
That is the file that fails printing. (2.11 MB, application/pdf)
2011-02-18 13:43 UTC, Fanen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fanen 2011-02-18 13:43:25 UTC
Created attachment 7259 [details]
That is the file that fails printing.

The Cups log is pasted below. I will be glad to perform further investigation if someone would tell me what todo.


D [18/Feb/2011:12:41:31 +0000] [Job 3] envp[20]="CONTENT_TYPE=application/pdf"
D [18/Feb/2011:12:41:31 +0000] [Job 3] envp[21]="DEVICE_URI=usb://EPSON/Stylus%20SX218"
D [18/Feb/2011:12:41:31 +0000] [Job 3] envp[22]="PRINTER_INFO=EPSON Epson Stylus SX218"
D [18/Feb/2011:12:41:31 +0000] [Job 3] envp[23]="PRINTER_LOCATION=nucco"
D [18/Feb/2011:12:41:31 +0000] [Job 3] envp[24]="PRINTER=Epson-Stylus-SX218"
D [18/Feb/2011:12:41:31 +0000] [Job 3] envp[25]="CUPS_FILETYPE=document"
D [18/Feb/2011:12:41:31 +0000] [Job 3] envp[26]="FINAL_CONTENT_TYPE=printer/Epson-Stylus-S
X218"
D [18/Feb/2011:12:41:31 +0000] [Job 3] Start rendering...
D [18/Feb/2011:12:41:31 +0000] [Job 3] Processing page 1...
D [18/Feb/2011:12:41:31 +0000] [Job 3] Error: /typecheck in --run--
D [18/Feb/2011:12:41:31 +0000] [Job 3] Operand stack:
D [18/Feb/2011:12:41:31 +0000] [Job 3] (/tmp/gs_iZxJFC)   --nostringval--   --dict:6/6(L)-
-   --dict:128/128(ro)(L)--   --dict:6/6(L)--   false   --dict:6/6(L)--   --dict:1/4(L)--   --dict:4/4(L)--   false   false   --nostringval--   --nostringval--   BM
D [18/Feb/2011:12:41:31 +0000] [Job 3] Execution stack:
D [18/Feb/2011:12:41:31 +0000] [Job 3] %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1878   1   3   %oparray_pop   1877   1   3   %oparray_pop   1861   1   3   %oparray_pop   --nostringval--   --nostringval--   --nostringval--   2   1   3   --nostringval--   %for_pos_int_continue   --nostringval--   --nostringval--   --nostringval--   --nostringval--   %loop_continue   --nostringval--   --nostringval--   --nostringval--   %loop_continue   --nostringval--   --nostringval--   --dict:2/2(L)--   --nostringval--   1   %dict_continue   --nostringval--   --nostringval--   %loop_continue   --nostringval--   --nostringval--
D [18/Feb/2011:12:41:31 +0000] [Job 3] Dictionary stack:
D [18/Feb/2011:12:41:31 +0000] [Job 3] --dict:1163/1684(ro)(G)--   --dict:1/20(G)--   --dict:75/200(L)--   --dict:75/200(L)--   --dict:108/127(ro)(G)--   --dict:287/300(ro)(G)--   --dict:21/25(L)--   --dict:4/6(L)--
D [18/Feb/2011:12:41:31 +0000] [Job 3] Current allocation mode is local
D [18/Feb/2011:12:41:31 +0000] [Job 3] Last OS error: 2
D [18/Feb/2011:12:41:31 +0000] [Job 3] GPL Ghostscript 8.71: Unrecoverable error, exit code 1
D [18/Feb/2011:12:41:31 +0000] [Job 3] Rendering completed
D [18/Feb/2011:12:41:31 +0000] [Job 3] Can't open CUPS raster file.
D [18/Feb/2011:12:41:31 +0000] [Job 3] End of messages
D [18/Feb/2011:12:41:31 +0000] [Job 3] printer-state=3(idle)
D [18/Feb/2011:12:41:31 +0000] [Job 3] printer-state-message="/usr/lib/cups/filter/pdftoraster failed"
D [18/Feb/2011:12:41:31 +0000] [Job 3] printer-state-reasons=none
Comment 1 Fanen 2011-02-18 13:44:54 UTC
It fails printing at page 5 (when printing starting from the last page)
Comment 2 Alex Cherepanov 2011-07-14 13:56:37 UTC
The problem is confirmed in v. 8.71 and v. 9.00, but it is fixed in v. 9.01
and higher. Please upgrade.