Bug 691332 - Wish an auto-reload feature
Summary: Wish an auto-reload feature
Status: RESOLVED FIXED
Alias: None
Product: MuPDF
Classification: Unclassified
Component: mupdf (show other bugs)
Version: unspecified
Hardware: PC Linux
: P4 enhancement
Assignee: Tor Andersson
QA Contact: Bug traffic
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-21 02:11 UTC by Ryo Furue
Modified: 2019-08-07 03:44 UTC (History)
2 users (show)

See Also:
Customer:
Word Size: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryo Furue 2010-05-21 02:11:50 UTC
I wish mupdf reloaded the file automatically  (on a page change or redraw) if it has changed since it was last loaded.  Since mupdf is light-weight, it's suitable as a previewer.

I would use mupdf as a previewer for pdflatex: Edit my LaTeX file on emacs, type C-c C-c, and mupdf would display the result; change the LaTeX source a little bit, type C-c C-c again, and mupdf would reload the file, displaying the revised contents.  Very sleek.  The only PDF viewer that has an auto-reload feature is xpdf as far as I know, but it's very old without any active maintainer and so it may be abandoned sooner or later.

Thank you for your attention,
Ryo
Comment 1 Tor Andersson 2010-05-23 13:41:45 UTC

*** This bug has been marked as a duplicate of bug 691330 ***
Comment 2 Ryo Furue 2010-05-23 19:35:58 UTC
> This bug has been marked as a duplicate of bug 691330

It's definitely not a duplicate!  Let's see what 691330 says:

>> Something like xpdf, with a few buttons and a context menu,
>> smart zooming, search, annotations and form filling.

I don't want those "few buttons", "context menu", "smart zooming", "search", "annotations", or "form filling"!  (I'm not saying those are bad ideas.)

All I want is auto-reloading.  If you merge my wish with 691330, my real wish will be lost, right?

So, please delete or disregard that part of my comment which mentions xpdf and leave my comment as separate.

Regards,
Ryo
Comment 3 Tor Andersson 2010-05-24 15:36:19 UTC
Your real wish will be fulfilled with the new UI. I put all UI enhancement requests with bug 691330.

I mentioned your request to Sebastian, since it's a good idea. He agreed and implemented it yesterday, so you don't have to wait for the new UI.
Comment 4 Ryo Furue 2010-05-24 17:26:57 UTC
(In reply to comment #3)
> Your real wish will be fulfilled with the new UI. I put all UI enhancement
> requests with bug 691330.
> 
> I mentioned your request to Sebastian, since it's a good idea. He agreed and
> implemented it yesterday, so you don't have to wait for the new UI.

Ah, thank you for your quick response!  I appreciate it very much.

Best regards,
Ryo