Bug 691046 - Memory handling problem when resolution too high
Summary: Memory handling problem when resolution too high
Status: RESOLVED DUPLICATE of bug 691499
Alias: None
Product: Ghostscript
Classification: Unclassified
Component: CUPS driver (show other bugs)
Version: 8.70
Hardware: PC Linux
: P4 normal
Assignee: Marcos H. Woehrmann
QA Contact: Bug traffic
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-05 08:42 UTC by Tim Waugh
Modified: 2010-08-12 19:03 UTC (History)
1 user (show)

See Also:
Customer:
Word Size: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Waugh 2010-01-05 08:42:55 UTC
With ghostscript-8.70 on Fedora 12, gs crashes while reclaiming memory after
gdevcups tries to allocate a very large buffer.

For instructions on how to reproduce this problem:
  https://bugzilla.redhat.com/show_bug.cgi?id=549901#c7

I haven't been able to figure out quite where the problem comes from.
Comment 1 Ray Johnston 2010-01-07 10:20:31 UTC
Marcos will try and reproduce.
Comment 2 Tim Waugh 2010-03-23 11:30:12 UTC
Setting the RIP_MAX_CACHE environment variable to "128m" works around the problem because the buffer allocation then succeeds.

So it's something to do with when allocations fail due to the space_params having been exceeded.
Comment 3 Till Kamppeter 2010-08-12 19:03:03 UTC
From the Ghostscript side already fixed in SVN rev 11547. But see my comments in

http://bugs.ghostscript.com/show_bug.cgi?id=691499

*** This bug has been marked as a duplicate of bug 691499 ***