Bug 690892 - regression bug when converting PDF image to PNG
Summary: regression bug when converting PDF image to PNG
Status: RESOLVED DUPLICATE of bug 690676
Alias: None
Product: Ghostscript
Classification: Unclassified
Component: General (show other bugs)
Version: 8.70
Hardware: PC Windows XP
: P4 normal
Assignee: Default assignee
QA Contact: Bug traffic
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-05 18:42 UTC by Uwe Stöhr
Modified: 2009-11-05 19:04 UTC (History)
0 users

See Also:
Customer:
Word Size: ---


Attachments
PDF image used to reproduce the bug (21.23 KB, application/pdf)
2009-11-05 18:44 UTC, Uwe Stöhr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Uwe Stöhr 2009-11-05 18:42:46 UTC
When I use the attached PDF file and try to convert it to a png using this
command with Ghostscript 8.70:

gs -q -dQUIET -dPARANOIDSAFER -dBATCH -dNOPAUSE -dNOPROMPT -dMaxBitmap=500000000
-dAlignToPixels=0 -dGridFitTT=0 "-sDEVICE=pnmraw" -dTextAlphaBits=4
-dGraphicsAlphaBits=4 "-r72x72" -dUseCropBox
"-sOutputFile=Resistance-Network.pnm" Resistance-Network.pdf

I get this error:
**** Page has no /MediaBox attribute. Using the current page size.
Error: /stackunderflow in --index--
Operand stack:
--dict:6/6(L)-- 595.0 842.0 3
Execution stack:
%interp_exit .runexec2 --nostringval-- --nostringval-- --nostringval-- 2
%stopped_push --nostringval-- --nostringval-- --nostringval-- false 1
%stopped_push 1862 1 3 %oparray_pop 1861 1 3 %oparray_pop 1845 1 3 %oparray_pop
--nostringval-- --nostringval-- 2 1 1 --nostringval-- %for_pos_int_continue
--nostringval-- --nostringval--
Dictionary stack:
--dict:1160/1684(ro)(G)-- --dict:1/20(G)-- --dict:75/200(L)-- --dict:75/200(L)--
--dict:106/127(ro)(G)-- --dict:285/300(ro)(G)-- --dict:21/25(L)-- --dict:2/6(L)--
Current allocation mode is local
GPL Ghostscript 8.70: Unrecoverable error, exit code 1

I think this is a regression to Ghostscript 8.65.
Comment 1 Uwe Stöhr 2009-11-05 18:44:24 UTC
Created attachment 5629 [details]
PDF image used to reproduce the bug
Comment 2 Alex Cherepanov 2009-11-05 19:04:16 UTC
Yes, this is a regression in v. 8.70.
It has been fixed shortly after the release. See bug 690676 for details.


*** This bug has been marked as a duplicate of 690676 ***