Bug 690760 - scrolling works only when windows has been moved (Linux/Xfce)
Summary: scrolling works only when windows has been moved (Linux/Xfce)
Status: RESOLVED DUPLICATE of bug 691330
Alias: None
Product: MuPDF
Classification: Unclassified
Component: mupdf (show other bugs)
Version: unspecified
Hardware: PC Linux
: P4 normal
Assignee: Tor Andersson
QA Contact: Bug traffic
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-11 04:31 UTC by Nathanael Schaeffer
Modified: 2010-05-21 00:03 UTC (History)
0 users

See Also:
Customer:
Word Size: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nathanael Schaeffer 2009-09-11 04:31:00 UTC
When starting mupdf, scrolling does not work (other keys like next, zoom, etc...
are working).

Touching the window (resizing or just moving) makes the key active.

Looks like mupdf is not aware of the real size of the window ?

This happens for me on Linux (ArchLinux) and with Xfce 4.6 as a window manager.
Comment 1 Ralph Giles 2009-09-11 08:57:23 UTC
I'm not sure what you mean. The mupdf application doesn't have a continuous-page
mode, so scrolling is only possible within the single displayed page, and then
only when the page image is larger than the window.

Can you clarify what you're doing, what you expect to happen, and what happens
instead?
Comment 2 Nathanael Schaeffer 2009-09-11 09:15:12 UTC
Sorry, here are some precisions :
When the program starts, the window takes up the whole height of the screen, but
the page does not fit into the window.
Then I expect that when pressing d, it will scroll down, but nothing happens.
Then I grab the title bar and move the window a little bit (resizing is not
required), and after that the page scrolls as expected (with the "d" key or with
the mouse)

I've been doing some more tests, and it appears that it has something to do with
my dual screen setup (two screens are on top of each other setup with xrandr)
and mupdf thinks that its window height is the total height of the screen (top +
bottom) while in fact the window only fills the top or bottom screen so that the
height is less.
When a page needs more pixels to be fully displayed that what is available (and
allocated by the window manager) on the current screen, but less than the total
virtual screen, then scrolling does not work as it should.

Hope this is clearer, feel free to ask more precisions.
Comment 3 Ralph Giles 2009-09-11 09:53:14 UTC
Yes, that helps a lot, thanks. I'd certainly believe there's a bug in the wm
interaction; that stuff is hard to get right.
Comment 4 Tor Andersson 2010-05-21 00:03:32 UTC

*** This bug has been marked as a duplicate of bug 691330 ***