Bug 687510 - pdfwrite: Acrobat 6.0 paints notdef instead spaces
Summary: pdfwrite: Acrobat 6.0 paints notdef instead spaces
Status: NOTIFIED INVALID
Alias: None
Product: Ghostscript
Classification: Unclassified
Component: PDF Writer (show other bugs)
Version: master
Hardware: PC Windows NT
: P2 normal
Assignee: Igor Melichev
QA Contact: Bug traffic
URL:
Keywords:
: 687620 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-06-10 00:10 UTC by Igor Melichev
Modified: 2008-12-19 08:31 UTC (History)
2 users (show)

See Also:
Customer: 130
Word Size: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Igor Melichev 2004-06-10 00:10:09 UTC
Viewing our PDF, the user observes boxes instead space characters.
The problem explanation appears in the bug 687464 starting from Comment #19.
I can't reproduce it on any of my systems, so passing it to Support.
Note that the users uses an obsolete Windows NT and may have a specific 
localization/font software installed.
Comment 1 KH Subrahmanyan 2004-06-14 02:06:38 UTC
Following are our Setup Environment:

- A service pack version number;
Microsoft Windows XP Professional Version 2002 Service Pack 1

- The PDF viewer version;
Adobe Acrobat Reader 6.0 Version 6.0.1  11/3/2003

- What locales are installed ?
EN (English United States)

- Which installed 3d party products could contrubute/modify fonts ?
No 3rd party Font Installation
Comment 2 Jack Moffitt 2004-06-16 09:48:58 UTC
Reassigning for reproduction.
Comment 3 KH Subrahmanyan 2004-06-29 05:29:21 UTC
Hi,
	Following are our Setup details.

----------------------------------------------------
Operating system: 	Windows 2000 Advanced server.
Ghostscript Version:	Artifex Ghostscript 8.13 (2003-12-31)
				Copyright (C) 2003 artofcode LLC, Benicia, CA.  
All rights reserved.
Command Used to Convert:
	gs -sDEVICE=pdfwrite -Ic:\hp\om\lib\FONTS\Soft_Horizons -
Ic:\hp\om\lib\PS -q -dBATCH -dNOPAUSE -dSAFER -dSHORTERRORS -dWRITESYSTEMDICT -
dGHOSTSCRIPT -sOutputFile=- gs_nostd.ps d:\defect\33685\input.ps > c:\output.pdf
----------------------------------------------------

We are able to reproduce the problem with gs 8.14 on HP-UX 11.00 also.
Ghostscript Version: 	Artifex Ghostscript 8.14 (2004-02-20)
				Copyright (C) 2004 artofcode LLC, Benicia, CA.  
All rights reserved.
Command Used to Convert:
	/build/adiga/os33/bin/gs -sDEVICE=pdfwrite -
I/build/adiga/os33/lib/FONTS/Soft_Horizons -I/build/adiga/os33/lib/PS -q -
dBATCH -dNOPAUSE -dSAFER -dSHORTERRORS -dWRITESYSTEMDICT -dGHOSTSCRIPT -
sOutputFile=- gs_nostd.ps /home/adiga/tmp/input.ps > output.pdf
----------------------------------------------------

We downloaded the Adobe acrobat reader from the following link:
http://www.adobe.com/products/acrobat/readstep2.html

The version of the adobe reader is 6.0.2 (I also tried in 6.0.1).

The same kind of set up with XP also gave the same output.
----------------------------------------------------

Please consider this as very urgent, and we want the Fix atleast by this 
weekend.

You can Get the Files from the following link.
1. Input PS File:
http://bugs.ghostscript.com/attachment.cgi?id=692&action=view
2. Output PDF File:
http://bugs.ghostscript.com/attachment.cgi?id=693&action=view
3. File showing the differences:
http://bugs.ghostscript.com/attachment.cgi?id=695&action=view

Please let me know if you want any more information.	

Thanks
Subrahmanyan.
Comment 4 Jack Moffitt 2004-07-06 12:32:28 UTC
Reassigning to Igor since I was able to reproduce the problem.
Comment 5 Jack Moffitt 2004-07-06 13:22:08 UTC
> I was finally able to reproduce this, but not on every system I tried.
> It seems unspecific to the fonts used, as I got the same result with
> both the Soft Horizons fonts you were using as well as the URW fonts.
>
> In Acrobat Reader 5.0.5 on GNU/Linux I didn't see the problem.  In
> Acrobat 5.0.5 on Windows XP Pro, I didn't see the problem, but on a
> different Windows XP Pro machine with Acrobat Reader 6.0.2, the problem
> appears.
>
> I tested both GS 8.14 and CVS HEAD (as of today) and both gave the same
> results.
Comment 6 KH Subrahmanyan 2004-07-13 01:42:49 UTC
Hi,
   Any updates on this?

Thanks and Regards,
Subrahmanyan.
Comment 7 Igor Melichev 2004-07-13 03:57:31 UTC
I updated to Adobe Reader 6.0.2 and still don't see the probelm.
Assigning the bug to Jack.
Jack please find out what diffetent software is installed on your 2 machines.
I still think that it's a 4th party software problem, which wasted fonts of the 
Adobe Reader on Microsoft Windows.
Comment 8 Igor Melichev 2004-07-14 10:53:56 UTC
Well, now I can see a reason for boxes.
The source PS file contains the "newline" ASCII character code 0x0D in the text 
(thanks to Raph), and the font's Encoding defines .notdef for it. The font is 
made from Courier, which is a standard font. The PDF generated with Ghostscript 
does exactly same. So the viewer must paint a notdef glyph, which is defined in 
the viewer's standard font. Thus the Ghostscript's behavior is correct, and the 
observed effect depends on the PDF viewer.

Adobe Distiller replaces this character with a shift to -600 design units by X, 
which likely emulates a caridge return. Note it's not same as a "newline". 
Likely Adobe Distiller implements an undocumented arbitrary hack.

My conclusion is to report this problem to "SAPscript, SAP R/3 rel.5.0A", which 
created the PS document. It should not supply undefined character codes, 
othervise the effect is a viewer dependent.
Comment 9 Igor Melichev 2004-08-24 11:31:27 UTC
*** Bug 687620 has been marked as a duplicate of this bug. ***