Bug 693679 - mouse scrolling painfully slow in 1.2
mouse scrolling painfully slow in 1.2
Status: RESOLVED FIXED
Product: MuPDF
Classification: Unclassified
Component: mupdf
master
PC Linux
: P4 major
Assigned To: Tor Andersson
Bug traffic
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-05 23:01 PST by Casey Jones
Modified: 2014-02-17 04:40 PST (History)
3 users (show)

See Also:
Customer:
Word Size: ---


Attachments
Removes extra MotionNotify events (393 bytes, patch)
2013-04-05 12:40 PDT, james.gray.public
Details | Diff
Removes extra MotionNotify and ConfigureNotify events (615 bytes, patch)
2013-04-21 05:45 PDT, james.gray.public
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Casey Jones 2013-03-05 23:01:40 PST
battlepanic described the problem perfectly in the Arch Linux forums.
https://bbs.archlinux.org/viewtopic.php?pid=1239765#p1239765
I'll simply copy+paste and confirm his account here:

"After upgrading mupdf from version 1.1 to 1.2, I have noticed that scrolling and panning across a document using the mouse is significantly slower.  It sometimes takes upwards of 10 seconds for the document to completely scroll to the desired position.  Interestingly, the issue is worse if I click and drag the mouse at a slower speed.
"Resizing the mupdf window suffers from a similar lag.  It takes much longer for the document to be recentered in the window as compared to version 1.1.
"Keyboard scrolling in mupdf using the hjkl keys appears unaffected."

I experience all the same issues exactly.
Comment 1 james.gray.public 2013-04-05 12:40:44 PDT
Created attachment 9491 [details]
Removes extra MotionNotify events

Please try this patch if mupdf is unable to respond quick enough to motion events.
Comment 2 stu-mupdf 2013-04-07 11:39:30 PDT
I see this too (on OpenBSD here). James, your diff works for me.
Comment 3 battlepanic 2013-04-07 18:12:54 PDT
(In reply to comment #1)
> Created attachment 9491 [details]
> Removes extra MotionNotify events
> 
> Please try this patch if mupdf is unable to respond quick enough to motion
> events.

James,

I tested your patch posted on 2013-04-05 and in my case, it looks like the patch provides only a partial fix:

RESOLVED:

Scrolling a panning a across document using the mouse appears to be fixed and now works as it did in mupdf-1.1.

UNRESOLVED:

When resizing the mupdf window, The document contained therein still takes much longer to be recentered as compared to mupdf-1.1.
Comment 4 james.gray.public 2013-04-21 05:45:13 PDT
Created attachment 9579 [details]
Removes extra MotionNotify and  ConfigureNotify events

Please try this patch if mupdf is unable to respond quick enough to motion events.

I have attempted to patch the other part of the problem regarding resizing, but since it does not occur on my system I am unable to test whether my patch is working or not.
Comment 5 battlepanic 2013-04-26 01:40:11 PDT
(In reply to comment #4)
> Created attachment 9579 [details]
> Removes extra MotionNotify and  ConfigureNotify events
> 
> Please try this patch if mupdf is unable to respond quick enough to motion
> events.
> 
> I have attempted to patch the other part of the problem regarding resizing,
> but since it does not occur on my system I am unable to test whether my
> patch is working or not.

After applying the patch, window resizing is is still noticeably worse than mupdf-1.1 but an improvement over mupdf-1.2.

It still takes longer for the document to be recentered in the window as compared to mupdf-1.1.

When enlarging the window, artifacts briefly appear along the right side and bottom portions of the window.