Bug 700139 - segmentation fault on device pngalpha
Summary: segmentation fault on device pngalpha
Status: RESOLVED WORKSFORME
Alias: None
Product: Ghostscript
Classification: Unclassified
Component: General (show other bugs)
Version: 9.25
Hardware: PC Linux
: P4 normal
Assignee: Default assignee
QA Contact: Bug traffic
URL:
Keywords:
: 700292 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-11-07 09:37 UTC by a.l.e
Modified: 2018-11-29 07:59 UTC (History)
1 user (show)

See Also:
Customer:
Word Size: ---


Attachments
pdf file that cannot be convert (1.56 MB, application/pdf)
2018-11-07 09:37 UTC, a.l.e
Details

Note You need to log in before you can comment on or make changes to this bug.
Description a.l.e 2018-11-07 09:37:31 UTC
Created attachment 16122 [details]
pdf file that cannot be convert

running the following comand on the attached file, leads to a segmentation fault

gs -q -dNOPAUSE -dQUIET -dPARANOIDSAFER -dBATCH -sDEVICE=pngalpha -dTextAlphaBits=4 -dGraphicsAlphaBits=4 -r300 -sOutputFile=test.png -dFirstPage=1 -dLastPage=1 -dUseArtBox mu-install-enUS-a4.pdf -c showpage

reducing the resolution avoids the crash, but i could not open the resulting png with gimp.

- scribus is using this command for embedding rasterized pdf in the final pdfs
- multiple users have reported that their pdfs are not working anymore
- a scribus developer is reporting that the command works with gs 9.23 but not with 9.24 and 9.25.
Comment 2 Ken Sharp 2018-11-29 07:59:12 UTC
*** Bug 700292 has been marked as a duplicate of this bug. ***