Bug 693724 - no UTF8 search
Summary: no UTF8 search
Status: RESOLVED FIXED
Alias: None
Product: MuPDF
Classification: Unclassified
Component: mupdf (show other bugs)
Version: master
Hardware: PC Linux
: P4 enhancement
Assignee: muPDF bugs
QA Contact: Bug traffic
URL:
Keywords:
: 694438 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-03-21 23:39 UTC by hvtaifwkbgefbaei
Modified: 2018-11-12 18:58 UTC (History)
9 users (show)

See Also:
Customer:
Word Size: ---


Attachments
Screenshot of mupdf-1.3 while searching with non-ASCII characters (like "évoluez") (33.01 KB, image/png)
2014-01-31 08:35 UTC, YuGiOhJCJ
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hvtaifwkbgefbaei 2013-03-21 23:39:58 UTC
only US-ASCII.
Comment 1 Tor Andersson 2013-11-28 02:45:48 UTC
The core search functionality in the mupdf library supports unicode. The x11 and win32 viewers don't. Fixing the viewers is an enhancement.
Comment 2 YuGiOhJCJ 2014-01-31 08:35:30 UTC
Created attachment 10636 [details]
Screenshot of mupdf-1.3 while searching with non-ASCII characters (like "évoluez")

I confirm this bug in the 1.3 version of mupdf.
See the attached screenshot of mupdf-1.3 while searching with non-ASCII characters (like "évoluez").
Comment 3 Tor Andersson 2014-05-21 06:09:17 UTC
*** Bug 694438 has been marked as a duplicate of this bug. ***
Comment 4 Valeriy Koval 2014-09-22 07:05:20 UTC
I'd like to confirm the issue.
I was trying to use Cyrillic characters to search for something. When I was typing the characters the didn't appear in the search input line at all.

Please let us know in what version you are planning to fix it.
Comment 5 dklovedoctor 2015-02-25 17:09:43 UTC
I'd like to confirm this issue. Searching in greek in not possible.
Comment 6 m5bere2 2015-06-14 08:12:43 UTC
This issue is much more important than a mere "enhancement": mupdf is essentially useless when working with non-english PDFs, since almost every other language contains non-ASCII characters.

Me personally this issue prevents from searching for words in Russian and German PDFs, since it is impossible to enter cyrillic letters or German umlauts (äöüß) into the search box.
Comment 7 Nikolay 2015-10-24 13:18:05 UTC
Version 1.7a. I'd like to confirm this issue. Search in Cyrillic is not possible.
Comment 8 Max 2015-11-14 05:59:26 UTC
1.8, still failing such a basic thing as a search: I think the priority should be set to critical.
Comment 9 Tor Andersson 2015-11-14 06:16:04 UTC
The (soon to be deprecated) win32/x11 viewer only supports ASCII search. The mobile viewers, and the mupdf-gl viewer both support unicode search.
Comment 10 Pablo Rodríguez 2015-12-05 06:37:40 UTC
(In reply to Tor Andersson from comment #9)
> The (soon to be deprecated) win32/x11 viewer only supports ASCII search. The
> mobile viewers, and the mupdf-gl viewer both support unicode search.

Tor, since win32 and x11 viewers will be deprecated soon, would it be possible to rename the mupdf-gl to simply mupdf?
Comment 11 Tor Andersson 2018-11-12 18:58:20 UTC
Use mupdf-gl if you need non-ASCII search.