Bug 693574 - mupdf needs a key to page down (as screen page, not pdf page) in zoom mode for continuous reading
Summary: mupdf needs a key to page down (as screen page, not pdf page) in zoom mode fo...
Status: RESOLVED FIXED
Alias: None
Product: MuPDF
Classification: Unclassified
Component: apps (show other bugs)
Version: master
Hardware: All All
: P4 enhancement
Assignee: muPDF bugs
QA Contact: Bug traffic
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-21 05:37 UTC by jamesfengcao
Modified: 2018-10-17 08:12 UTC (History)
5 users (show)

See Also:
Customer:
Word Size: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jamesfengcao 2013-01-21 05:37:21 UTC
mupdf is such a great piece of software only if this minor issue is fixed.
When in zoom mode, users usually do not care at boundary of pdf pages, but all keys for scrolling (pageDown, space, j,k,->,<-,up,down,'b',',' and '.' are all related to pdf pages, and none of them works for continuous reading).

It becomes such a pain that I gave up mupdf and now I use zathura. I will remove zathura after this minor issue is resolved.

Please, fix the issue since I am a fan of mupdf and do not want to use other pdf viewer.
Best Regards
Jim
Comment 1 Robin Watts 2013-01-22 17:16:14 UTC
Downgrading to enhancement. Please don't fiddle with the 'importance' field.

Thanks for your report.
Comment 2 james.gray.public 2014-01-13 03:01:21 UTC
A small patch that might help is available here: http://bugs.ghostscript.com/show_bug.cgi?id=693425
Comment 3 emarsk 2014-05-20 10:18:36 UTC
Hi, I registered just to support this feature request.
As the OP said, I too would use mupdf, if wouldn't for this issue.
I'll try the patch.
Comment 4 Tor Andersson 2014-05-21 06:25:13 UTC

*** This bug has been marked as a duplicate of bug 691330 ***
Comment 5 Tor Andersson 2018-10-17 08:12:48 UTC
The space and 'b' keys in mupdf-gl does paging by screenfuls.