Bug 692690 - Ghostscript fails at pdf -> jpg conversion
Summary: Ghostscript fails at pdf -> jpg conversion
Status: RESOLVED FIXED
Alias: None
Product: Ghostscript
Classification: Unclassified
Component: PDF Interpreter (show other bugs)
Version: 9.04
Hardware: PC Linux
: P4 major
Assignee: Alex Cherepanov
QA Contact: Bug traffic
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-18 16:36 UTC by Juliusz Gonera
Modified: 2011-11-18 22:55 UTC (History)
0 users

See Also:
Customer:
Word Size: ---


Attachments
Failing pdf input (37.62 MB, application/pdf)
2011-11-18 16:36 UTC, Juliusz Gonera
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juliusz Gonera 2011-11-18 16:36:51 UTC
Created attachment 8129 [details]
Failing pdf input 

Sample .pdf input included

Invocation
-----------

ghostscript-9.04 -q -dBATCH -dNOPAUSE -sDEVICE=jpeg -r200x200 -sOutputFile=page_%02d.jpg file.pdf

Trace
------

   **** Warning: considering '0000000000 XXXXX n' as a free entry.                                                     
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.                                                      
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning: considering '0000000000 XXXXX n' as a free entry.
   **** Warning:  File has an invalid xref entry:  4447.  Rebuilding xref table.
   **** Warning: stream Length incorrect.
Error: /typecheck in --run--
Operand stack:
   --dict:6/6(L)--   --dict:65/65(ro)(L)--   --dict:6/6(L)--   false   --dict:6/6(L)--   --dict:1/4(L)--   --dict:5/5(L)--   f
alse   --nostringval--   --nostringval--   Subtype
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --no
stringval--   --nostringval--   false   1   %stopped_push   1910   1   3   %oparray_pop   1909   1   3   %oparray_pop   1893  
 1   3   %oparray_pop   --nostringval--   --nostringval--   13   1   56   --nostringval--   %for_pos_int_continue   --nostring
val--   --nostringval--   --nostringval--   --nostringval--   %loop_continue   --nostringval--   --nostringval--   --nostringv
al--   %loop_continue   --nostringval--   --nostringval--   --dict:13969/13969(L)--   --nostringval--   12438   %dict_continue
   --nostringval--
Dictionary stack:
   --dict:1157/1684(ro)(G)--   --dict:1/20(G)--   --dict:82/200(L)--   --dict:82/200(L)--   --dict:108/127(ro)(G)--   --dict:2
91/300(ro)(G)--   --dict:24/30(L)--   --dict:4/6(L)--
Current allocation mode is local
Last OS error: 2
GPL Ghostscript 9.04: Unrecoverable error, exit code 1
Comment 1 Alex Cherepanov 2011-11-18 22:55:10 UTC
The problem is fixed in the current development version.
You can clone our git repository or get a current snapshot here
http://git.ghostscript.com/?p=ghostpdl.git;a=summary

Ghostscript development uses continuous integration model,
and regression are not tolerated.