Bug 692452 - Make viewer turn http://blah/ etc text into clickable links
Summary: Make viewer turn http://blah/ etc text into clickable links
Status: RESOLVED DUPLICATE of bug 691330
Alias: None
Product: MuPDF
Classification: Unclassified
Component: mupdf (show other bugs)
Version: unspecified
Hardware: PC All
: P4 enhancement
Assignee: Tor Andersson
QA Contact: Bug traffic
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-22 03:19 UTC by sethyan
Modified: 2012-07-20 12:22 UTC (History)
2 users (show)

See Also:
Customer:
Word Size: ---


Attachments
external link not be rendered into the page (839.24 KB, application/pdf)
2011-08-22 03:19 UTC, sethyan
Details
bug692452-2.pdf (2.13 KB, application/pdf)
2012-01-05 01:11 UTC, Robin Watts
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sethyan 2011-08-22 03:19:45 UTC
Created attachment 7809 [details]
external link not be rendered into the page

See attachment pdf file, on the bottom of each page there has a external link, but in MuPDF there is nothing but blank. Is it missing to render?
Comment 1 sethyan 2011-08-22 05:42:05 UTC
Sorry for incorrect description. On the bottom of each page there has a external link(URL), in Adobe Arcobat it can be click and jump to that website, but in MuPDF it cannot be click, it is just a normal text but not a link.
Comment 2 Robin Watts 2012-01-05 01:11:21 UTC
Created attachment 8248 [details]
bug692452-2.pdf

Simplified file containing just a single form with a text string in, that acrobat magically turns into a link.

I think Acrobat may be doing some magic spotting of things that look like URLs.
Comment 3 zeniko 2012-01-05 11:53:48 UTC
It does indeed. We do support a subset of such text-links by extracting all text in a page and then looking for URL-like words/sentences, so that we support about half the links from my "599 - pseudo-links.pdf".
Comment 4 Robin Watts 2012-01-06 15:51:21 UTC
So, to retitle/reclassify the bug; the desire would be to amend the viewers functionality by turning 'link like' text into clickable links.

The core code is already capable of being driven to do this (existence proof - sumatra).

As such this is an enhancement rather than a bug.
Comment 5 Tor Andersson 2012-07-20 12:22:41 UTC

*** This bug has been marked as a duplicate of bug 691330 ***