Bug 692426 - let configure check for time.h
Summary: let configure check for time.h
Status: RESOLVED FIXED
Alias: None
Product: Ghostscript
Classification: Unclassified
Component: Build Process (show other bugs)
Version: master
Hardware: PC Linux
: P4 normal
Assignee: Chris Liddell (chrisl)
QA Contact: Bug traffic
URL:
Keywords:
: 692443 692751 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-08-12 13:09 UTC by Chris Liddell (chrisl)
Modified: 2011-12-19 08:47 UTC (History)
3 users (show)

See Also:
Customer:
Word Size: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Liddell (chrisl) 2011-08-12 13:09:35 UTC
and don't rely on the hard coded path check in unix-aux.mak
Comment 1 Chris Liddell (chrisl) 2011-08-18 17:27:24 UTC
*** Bug 692443 has been marked as a duplicate of this bug. ***
Comment 2 Chris Liddell (chrisl) 2011-08-18 17:28:36 UTC
It seems time.h has moved in some distributions, and this results in:

compilation error: gs/base/time_.h:49:8: error: redefinition of ‘struct timeval’ 


Added here in there hope that someone might search before creating a new bug.
Comment 3 Chris Liddell (chrisl) 2011-08-19 10:58:32 UTC
Fixed in:

http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=714766
Comment 4 Chris Liddell (chrisl) 2011-12-19 08:47:08 UTC
*** Bug 692751 has been marked as a duplicate of this bug. ***