Bug 691410 - PDF file which does not render on X11alpha
Summary: PDF file which does not render on X11alpha
Status: RESOLVED FIXED
Alias: None
Product: Ghostscript
Classification: Unclassified
Component: PDF Interpreter (show other bugs)
Version: master
Hardware: PC Linux
: P4 normal
Assignee: Michael Vrhel
QA Contact: Bug traffic
URL:
Keywords:
: 691263 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-06-22 19:13 UTC by Till Kamppeter
Modified: 2011-04-09 04:44 UTC (History)
2 users (show)

See Also:
Customer:
Word Size: ---


Attachments
Offending file. (318.09 KB, application/pdf)
2010-06-22 19:13 UTC, Till Kamppeter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Till Kamppeter 2010-06-22 19:13:14 UTC
Created attachment 6394 [details]
Offending file.

The attached PDF file does not render:

till@till:~/ghostscript/gpl/gs-test$ gs ~/ghostscript/gpl/testfiles/CityMap.pdf  
GPL Ghostscript 8.71 (2010-02-10)
Copyright (C) 2010 Artifex Software, Inc.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Processing pages 1 through 1.
Page 1
Error: /rangecheck in --run--
Operand stack:
   --dict:12/21(L)--
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1878   1   3   %oparray_pop   1877   1   3   %oparray_pop   1861   1   3   %oparray_pop   --nostringval--   --nostringval--   2   1   1   --nostringval--   %for_pos_int_continue   --nostringval--   --nostringval--   false   1   %stopped_push   --nostringval--   --nostringval--
Dictionary stack:
   --dict:1153/1684(ro)(G)--   --dict:1/20(G)--   --dict:75/200(L)--   --dict:75/200(L)--   --dict:108/127(ro)(G)--   --dict:288/300(ro)(G)--   --dict:22/25(L)--   --dict:6/8(L)--   --dict:22/40(L)--
Current allocation mode is local
Last OS error: 11
GPL Ghostscript 8.71: Unrecoverable error, exit code 1
till@till:~/ghostscript/gpl/gs-test$ 

Same error occurs when using the SVN HEAD.

I am on Ubuntu Maverick, 64-bit.

evince renders the file perfectly.
Comment 1 Hin-Tak Leung 2010-06-23 09:49:27 UTC
*** Bug 691263 has been marked as a duplicate of this bug. ***
Comment 2 Hin-Tak Leung 2010-06-23 09:52:45 UTC
I filed bug 691363 a couple of months ago - likely the same files for x11alpha/x11. Probably transparency-related and belong to Michael.
Comment 3 Till Kamppeter 2010-06-23 10:02:05 UTC
Hin-Tak, you mean bug 691263 in comment #2.
Comment 4 Hin-Tak Leung 2010-06-23 10:08:20 UTC
(In reply to comment #3)
> Hin-Tak, you mean bug 691263 in comment #2.

Argh, you are right.
Comment 5 Alex Cherepanov 2010-06-24 18:33:07 UTC
Reassigning x11alpha issue to Michael.
Comment 6 Michael Vrhel 2011-04-01 18:57:24 UTC
hmmm. not seeing a crash with the head on this, but getting a blank page.
Comment 7 Michael Vrhel 2011-04-09 04:44:35 UTC
Renders correctly with rev 12380