Bug 691110 - don't abort in OOM situations due to excessive zooming
Summary: don't abort in OOM situations due to excessive zooming
Status: RESOLVED DUPLICATE of bug 691330
Alias: None
Product: MuPDF
Classification: Unclassified
Component: fitz (show other bugs)
Version: unspecified
Hardware: PC Windows XP
: P4 normal
Assignee: Tor Andersson
QA Contact: Bug traffic
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-12 16:02 UTC by zeniko
Modified: 2010-05-20 23:58 UTC (History)
0 users

See Also:
Customer:
Word Size: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zeniko 2010-02-12 16:02:56 UTC
Per http://code.google.com/p/sumatrapdf/issues/detail?id=841 , at least fz_newpixmap successfully handles OOM.
Comment 1 Tor Andersson 2010-05-20 23:58:00 UTC
Wouldn't it be better to render only the visible part of the page when the zoom factor/page is too large to fit comfortably in memory?

*** This bug has been marked as a duplicate of bug 691330 ***