Bug 690899 - Error /stackunderflow
Summary: Error /stackunderflow
Status: RESOLVED DUPLICATE of bug 690676
Alias: None
Product: Ghostscript
Classification: Unclassified
Component: PDF Interpreter (show other bugs)
Version: 8.70
Hardware: PC Windows NT
: P4 major
Assignee: Alex Cherepanov
QA Contact: Bug traffic
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-09 04:06 UTC by Harry McKame
Modified: 2009-11-09 11:01 UTC (History)
0 users

See Also:
Customer:
Word Size: ---


Attachments
bon_retour.pdf (2.70 KB, application/pdf)
2009-11-09 04:08 UTC, Harry McKame
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Harry McKame 2009-11-09 04:06:45 UTC
On the attached pdf file, the following command gives an error:

"C:\Program Files\Ghostscript\gs8.70\bin\gswin32.exe" "-Ic:\program
files\Ghostscript\gs8.70\lib;c:\program files\Ghostscript\fonts" -dNOPAUSE
-dBATCH -dSAFER -dEPSCrop -dUseCropBox -f -q -sDEVICE=jpeg -sOutputFile=pdf.jpg
bon_retour.pdf

However, if you issue the same command but without the parameter "-dUseCropBox",
then gswin32 completes successfully.

The full error we're getting is (by OCR) :

Page has no /MediaBox attribute. Using the current page size.
Error: /stackunderflow in --index--
Operand stack: --dict:4/4(L)-- 612.0 792.0 3 
Execution stack: %interp_exit .runexec2 --nostringval-- --nostringval--
--nostringval-2 %stopped_push --nostringval-- --nostringval-- --nostringval-- fa
lse 1 %stopped_push 1862 1 3 %oparray_pop 1861 1 3 %oparray_ op 1845 1 3
%oparray_pop --nostringval-- --nostringval-- 2 1 1 --nostringval--
%for_pos_int_continue --nostringval-- --nostringval-- 
Dictionary stack: --dict:1156/1684(ro)(G)-- --dict:1/20(G)-- --dict:75/200(L)--
--dict:75 200(L)-- --dict:106/127(ro)(G)-- --dict:285/300(ro)(G)--
--dict:21/25(L)- - --dict:2/6(L)--
Current allocation mode is local 
GPL Ghostscript 8.70: Unrecoverable error, exit code 1
Comment 1 Harry McKame 2009-11-09 04:08:21 UTC
Created attachment 5647 [details]
bon_retour.pdf

PDF file on which we encounter the error
Comment 2 Alex Cherepanov 2009-11-09 11:01:26 UTC
Yes, this is a regression in v. 8.70.
It has been fixed shortly after the release. See bug 690676 for details.


*** This bug has been marked as a duplicate of 690676 ***