Bug 690664 - PDF file does not display on the screen
Summary: PDF file does not display on the screen
Status: RESOLVED FIXED
Alias: None
Product: Ghostscript
Classification: Unclassified
Component: X Display Driver (show other bugs)
Version: 8.70
Hardware: PC Linux
: P4 major
Assignee: Michael Vrhel
QA Contact: Bug traffic
URL:
Keywords: bountiable
Depends on:
Blocks:
 
Reported: 2009-07-29 02:24 UTC by Till Kamppeter
Modified: 2011-04-09 05:14 UTC (History)
1 user (show)

See Also:
Customer:
Word Size: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Till Kamppeter 2009-07-29 02:24:10 UTC
The PDF file invoice-reduced.pdf, attached to bug 690189 does not display on the
screen with Ghostscript 8.70. What gets shown is simply a blank page. All other
output devices (for example "png16m") handle the file correctly (therefore bug
690189 is fixed).
Comment 1 Ken Sharp 2009-07-29 06:14:45 UTC
Hmm, my results are different, but also incorrect. I tried it here on my Fedora
setup and it does display, but colours are inverted. That is, the image is
mostly black with white text....

I then selected the tiff24nc device, and got the same result. tried pbmraw, same
result, tried png16m, same result.

I quickly checked a couple of other PDF files and they were OK, tried on Windows
and invoice-reduced displays OK.
Comment 2 Till Kamppeter 2009-07-29 06:21:32 UTC
For me at least "png16m" gives the correct result (on Ubuntu Karmic, GS 8.70RC1
Debian-packaged without patches applied to the code of GS).
Comment 3 Ken Sharp 2009-07-29 06:26:13 UTC
It appears that the image in the PDF file is a soft mask, inside a Pattern :-(
The page content stream sets the Pattern colour space and then fills a rectangle
(full page, 612x792) with it.

Possibly one for Michael to look at ?

Comment 4 Ray Johnston 2009-07-29 09:36:39 UTC
Please specify the device you are using -- 'screen' is ambiguous.

On many linux/unix systems the default device is x11alpha and there are known
problems with x11alpha and pages with transparency (bugs currently open).

If the default device is x11alpha, please try with -sDEVICE=x11
Comment 5 Till Kamppeter 2009-07-29 09:58:22 UTC
You are right. With "x11alpha" the mentioned problem occurs, with "x11" the file
displays correctly.
Comment 6 Till Kamppeter 2009-07-29 10:21:47 UTC
Can you put references to the x11alpha transperency bugs here?
Comment 7 Ray Johnston 2009-07-30 10:11:47 UTC
This needs fixing to make GraphicsAlphaBits=4 compatible with transparency.
Comment 8 Michael Vrhel 2011-04-09 05:14:02 UTC
This renders correctly as of rev 12380