Bug 690033 - pstoraster crashes depend from Quality and Resolution requested
Summary: pstoraster crashes depend from Quality and Resolution requested
Status: RESOLVED DUPLICATE of bug 691499
Alias: None
Product: Ghostscript
Classification: Unclassified
Component: CUPS driver (show other bugs)
Version: 8.62
Hardware: PC FreeBSD
: P4 normal
Assignee: Marcos H. Woehrmann
QA Contact: Bug traffic
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-20 11:46 UTC by regisr
Modified: 2010-08-12 19:07 UTC (History)
1 user (show)

See Also:
Customer:
Word Size: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description regisr 2008-08-20 11:46:39 UTC
With a software using CUPS driver to print (like glabels) some resolutions /
quality print cause the crash of pstoraster (err 11)

Quality set to "Best": crash for any resolution
Other quality: crash for resolution greater than 1440x1440

Michael Sweet asked me to increase the RIP cache to 128MB (cupsctl RIPCache=128m):
every quality for any resolution works.
Comment 1 Ray Johnston 2008-08-21 13:32:49 UTC
Marcos to evaluate.
Comment 2 Heino Goldenstein 2008-09-04 06:49:42 UTC
Hi,

I get also a crash in pstoraster. My finding was it depends on
how the data was provided. I did a test where I created an logo
on 10 pages ARCHB.transvers. If I create the data as 10 pages
PNG 600dpi images pstorster crashes. If i create it as SVG
Image spanning the 10 pages all works well.
I have to ps-testfiles to show the effect. They can be
uploaded on request (1.5 MB as tar.gz). They should render
both to the same result.
Comment 3 Till Kamppeter 2010-08-12 19:07:29 UTC
From the Ghostscript side already fixed in SVN rev 11547. But see my comments
in

http://bugs.ghostscript.com/show_bug.cgi?id=691499

*** This bug has been marked as a duplicate of bug 691499 ***