Bug 691973

Summary: mupdf needs a Nup like 2up or two page mode but allowing more than 2 pages across
Product: MuPDF Reporter: Daniel Dutkiewicz <dsdutkiewicz>
Component: appsAssignee: Tor Andersson <tor.andersson>
Status: RESOLVED DUPLICATE QA Contact: Bug traffic <tech>
Severity: normal    
Priority: P4    
Version: unspecified   
Hardware: PC   
OS: Linux   
Customer: Word Size: ---

Description Daniel Dutkiewicz 2011-02-15 16:14:22 UTC
the _n-up page_ where n pages like the 2-up display that most have shows more then one page but unlike like the 2-up this isn't limited to just 2 pages

uplib's readup has a 2up mode and has the behavior of switching 1 page at a time i.e. if [1][2] are shown going forward makes [2][3] this is step by page while step by screen would do [1][2] to [3][4]

call mupdf as mupdf [pdf] 1-2 you'd get a two page display -- the pages listed must be contiguous as discontiguous ranges are better handled by cloning the window and setting each separately   

if you press a key the number of displayed pages (the span) increases from 1 to 2 and so on like [1] => [1][2] or decreases with another key like [1][2] => [1] this would also support [1][2] => [1][2][3] etc. 

set limit of 4 pages of span would be sufficient (clearly marked as a #define) and would protect one from accidentally eating up a lot of memory

when paging forward there are two modes now: one page and one screen
- in one page: we go from [1] => [2] or [1][2] => [2][3]
- in one screen: we go from [1] => [2] or [1][2] => [3][4]

the current page is consider the left most one so when searching etc. the viewer pages like it does now

so to summarize: this needs the allocation of four keys named:
- next-screen (like next-page)
- back-screen (like back-page)
- increase-span
- decrease-span
Comment 1 Tor Andersson 2011-04-10 13:57:23 UTC

*** This bug has been marked as a duplicate of bug 691330 ***