Bug 690823

Summary: Error: /rangecheck in --run-- on some PDF files
Product: Ghostscript Reporter: Adrian Johnson <ajohnson>
Component: PDF InterpreterAssignee: Alex Cherepanov <alex>
Status: RESOLVED DUPLICATE QA Contact: Bug traffic <tech>
Severity: normal    
Priority: P4    
Version: 8.70   
Hardware: PC   
OS: Linux   
Customer: Word Size: ---
Attachments: inkscape.pdf
gnome-report-2009-Q2.pdf

Description Adrian Johnson 2009-10-16 04:13:40 UTC
I have been getting reports of Ghostcript crashing on some cairo generated PDF
files. Adobe Reader and Poppler display the same files correctly with out
errors. I can not see anything obviously wrong with the PDF files so it appears
it may be a Ghostscript bug.
Comment 1 Adrian Johnson 2009-10-16 04:15:31 UTC
Created attachment 5495 [details]
inkscape.pdf

PDF file that crashes ghostscript.
Comment 2 Adrian Johnson 2009-10-16 04:16:02 UTC
Created attachment 5496 [details]
gnome-report-2009-Q2.pdf

Another PDF file that crashes ghostscript.
Comment 3 Ken Sharp 2009-10-16 04:40:38 UTC
Looks like yet another manifestation of the x11alpha driver failing with
transparent PDF files. The PDF works fine on GS under Windows, and using the X11
device, fails as described with the x11alpha device.

See #689150, #689734, #690813


*** This bug has been marked as a duplicate of 689150 ***