Bug 691759 - When printing PDF files, images are inverted (negative).
When printing PDF files, images are inverted (negative).
Status: RESOLVED FIXED
Product: Ghostscript
Classification: Unclassified
Component: Images
9.00
PC Linux
: P4 major
Assigned To: Alex Cherepanov
Bug traffic
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-09 05:41 PST by Jakub Schmidtke
Modified: 2014-02-17 04:41 PST (History)
3 users (show)

See Also:
Customer:
Word Size: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jakub Schmidtke 2010-11-09 05:41:23 PST
I have OKI B410d printer, using OKI's own driver, available here:
ftp://ftp2.okidata.com/pub/drivers/linux/SFP/monochrome/desktop/OK400PCL.tar.gz

Everything is fine with ghostscript 8.71, upgrading to 9.00 causes images in PDF files to be printed in negative.
I thought it was a problem with my .tex files or pdflatex or png files themselves.
PDF files that contain png images with transparency cause the entire page to be negative (even the regular text!). Without transparency just the png file is negative. JPG files are negative as well, converting between png, eps and pdf formats doesn't help either. I even tried taking a screenshot of a png image ;)
Creating a negative png image, putting it in the .tex document and printing that results in correct printout (the same as when original image and ghostscript 8.71 is used).

I also tried printing a pdf file downloaded from the Internet, from this tutorial:
http://www.andy-roberts.net/misc/latex/latextutorial5.html (this file: http://www.andy-roberts.net/misc/latex/tutorial5/import.pdf )
and the images were inverted as well.

Downgrading to 8.71 solves the problem...

There are other people that have the same (or similar) problem with different drivers and printers: https://bbs.archlinux.org/viewtopic.php?pid=850972
Comment 1 Jakub Schmidtke 2010-11-10 01:46:27 PST
I have tried procedure for reproducing the ghostscript bug described here:
http://bugs.ghostscript.com/show_bug.cgi?id=691733
When I use version 8.71 I get correct output, when
9.00 is used the first page looks fine, the others
are just garbage. However, when I used http://www.andy-roberts.net/misc/latex/tutorial5/import.pdf file (converted to ps with pdf2ps)
instead of C09-print-20101109-pstops-djd1400.ps,
the output looks horrible in both cases, but with ghostscript 9.00
the images are inverted. Still, I'm not sure if this is the same bug...
Comment 2 Chris Liddell (chrisl) 2010-11-10 11:54:10 PST
This looks very much the same issue as Bug 691733. If not, this bug can be reopened when Bug 691733 is fixed, and it can be tested.

*** This bug has been marked as a duplicate of bug 691733 ***
Comment 3 Jakub Schmidtke 2011-01-07 11:42:10 PST
It looks like bug 691733 has been solved, but this one remains.
Comment 4 Michael Vrhel 2011-01-07 18:29:43 PST
This has been fixed with rev 12005.