Bug 691203 - can only print fully black page - pstoraster-error
can only print fully black page - pstoraster-error
Status: RESOLVED DUPLICATE of bug 691108
Product: Ghostscript
Classification: Unclassified
Component: CUPS driver
8.71
PC Linux
: P4 critical
Assigned To: Michael Sweet
Bug traffic
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-19 08:39 PDT by Andrwe
Modified: 2011-12-24 07:32 PST (History)
2 users (show)

See Also:
Customer:
Word Size: ---


Attachments
The r10890 commit from Till, as a patch (4.05 KB, patch)
2010-03-20 12:59 PDT, Hin-Tak Leung
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andrwe 2010-03-19 08:39:38 PDT
Hi,

since the update of ghostscript to version 8.71 there are many reportings in the forum of Arch Linux about an error.

http://bbs.archlinux.org/viewtopic.php?pid=727987#p727987
http://bbs.archlinux.org/viewtopic.php?id=91272

The error occuring is that everyone prints a black page until they downgrade to ghostscript 8.70.

Maybe it is related to Arch Linux but we didn't found the reason yet.

The message occuring in the log of cups is 
"(/usr/lib/cups/filter/pstoraster) crashed on segnal 11!"

Here are some printers where teh problem occurs:

Epson D92
Canon Pixma MP830
Epson DX4050
Epson CX7300
Epson SX600FW
Epson DX3850
Comment 1 Hin-Tak Leung 2010-03-19 08:48:12 PDT
This is most likely a duplicate of bug 691108 which had us (and Redhat and Ubuntu) worried for a while, and was fixed by SVN rev 10890 . Please backport that commit and see if it fixes yours problem.

Please re-open if r10890 does not fix issues.

*** This bug has been marked as a duplicate of bug 691108 ***
Comment 2 linas_fi 2010-03-20 12:10:54 PDT
Confirmed. Doesn't segfault any more for me on latest svn.ghostscript.com
The mirror at code.google.com is outdated, though.
Comment 3 Hin-Tak Leung 2010-03-20 12:59:25 PDT
Created attachment 6108 [details]
The r10890 commit from Till, as a patch

The bug fix commit as a patch, for those who wants to try it.